summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-06-07 00:20:21 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-06-07 00:50:05 +0200
commita2265ea316d50a7063f193daf83770222f8c4cd8 (patch)
treee762c9b13fdf43c914aa4f2f449d09b4fe51b5f8
parentf608f40c35d37bc41614dfb63f211b6c69137702 (diff)
downloadguix-a2265ea316d50a7063f193daf83770222f8c4cd8.tar.gz
gnu: libnl: Update to 3.3.0.
Since version 3.2.5, signed tarballs are distributed via GitHub. See e.g.
release announcements:
https://lists.infradead.org/pipermail/libnl/2017-May/002313.html
The home page is somewhat outdated, but still hosts mailing lists and git mirror.

* gnu/packages/linux.scm (libnl): Update to 3.3.0.
[source]: Switch to new release URL.
-rw-r--r--gnu/packages/linux.scm9
1 files changed, 5 insertions, 4 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index b869a457c4..217647e071 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -1291,15 +1291,16 @@ transparently through a bridge.")
 (define-public libnl
   (package
     (name "libnl")
-    (version "3.2.25")
+    (version "3.3.0")
     (source (origin
               (method url-fetch)
               (uri (string-append
-                    "http://www.infradead.org/~tgr/libnl/files/libnl-"
-                    version ".tar.gz"))
+                    "https://github.com/thom311/libnl/releases/download/"
+                    "libnl" (string-join (string-split version #\.) "_")
+                    "/libnl-" version ".tar.gz"))
               (sha256
                (base32
-                "1icfrv8yihcb74as1gcgmp0wfpdq632q2zvbvqqvjms9cy87bswb"))))
+                "1r3lw3hjvqxi5zqyq2w1qadm3gisd9nlf71dkl4yplacmssnhm3h"))))
     (build-system gnu-build-system)
     (native-inputs `(("flex" ,flex) ("bison" ,bison)))
     (home-page "http://www.infradead.org/~tgr/libnl/")