summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-02 15:48:18 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-02 16:33:57 +0100
commitabe50aa369d43e95966c12146f542f44d5fef8d1 (patch)
treec9ec34873c7d7b6a552cc0d050b2923d64617c5d
parentffabccb22f2af42528d534a0150c5c69608f4942 (diff)
downloadguix-abe50aa369d43e95966c12146f542f44d5fef8d1.tar.gz
gnu: Add python-prometheus-client.
* gnu/packages/python.scm (python-prometheus-client,
python2-prometheus-client): New variables.
-rw-r--r--gnu/packages/python.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 8613edec9f..f2b24481ef 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7113,6 +7113,31 @@ convert an @code{.ipynb} notebook file into various static formats including:
 (define-public python2-nbconvert
   (package-with-python2 python-nbconvert))
 
+(define-public python-prometheus-client
+  (package
+    (name "python-prometheus-client")
+    (version "0.5.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "prometheus_client" version))
+       (sha256
+        (base32
+         "0g7rpv1pq2lab1nfqdx98z9d3bqwc400alg1j4ynrpjkrbsizhg8"))))
+    (build-system python-build-system)
+    (arguments '(#:tests? #f)) ; tests are not included
+    (propagated-inputs
+     `(("python-twisted" ,python-twisted)))
+    (home-page "https://github.com/prometheus/client_python")
+    (synopsis "Python client for the Prometheus monitoring system")
+    (description
+     "This package provides a Python client for the Prometheus monitoring
+system.")
+    (license license:asl2.0)))
+
+(define-public python2-prometheus-client
+  (package-with-python2 python-prometheus-client))
+
 (define-public python-notebook
   (package
     (name "python-notebook")