summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-03-10 14:48:33 +0100
committerMarius Bakke <mbakke@fastmail.com>2018-03-18 00:19:57 +0100
commitba57d602e32b615b26bda0269470e1478e79a391 (patch)
tree2865065e62194e9ebefb029ff991a8f0db891349
parent5b6f1be7833661fc359d51a7b0a82ae8f48348e5 (diff)
downloadguix-ba57d602e32b615b26bda0269470e1478e79a391.tar.gz
gnu: Switch from xineramaproto to xorgproto.
* gnu/packages/xorg.scm (xineramaproto)[properties]: Mark as superseded by
XORGPROTO.
(libxinerama)[propagated-inputs]: Replace XINERAMAPROTO with XORGPROTO.
(xorg-server)[propagated-inputs]: Remove XINERAMAPROTO.
-rw-r--r--gnu/packages/xorg.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index 83cb891823..e2cfef3a94 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -3678,8 +3678,8 @@ This extension provides a common network protocol for querying information
 which may be provided by different underlying screen combination
 technologies in the X server, such as the original Xinerama multiplexer, or
 alternative implementations like XRandR or TwinView.")
-    (license license:x11)))
-
+    (license license:x11)
+    (properties `((superseded . ,xorgproto)))))
 
 (define-public xinput
   (package
@@ -4574,7 +4574,7 @@ cannot be adequately worked around on the client side of the wire.")
             "1qlqfvzw45gdzk9xirgwlp2qgj0hbsyiqj8yh8zml2bk2ygnjibs"))))
     (build-system gnu-build-system)
     (propagated-inputs
-      `(("xineramaproto" ,xineramaproto)))
+      `(("xorgproto" ,xorgproto)))
     (inputs
       `(("libxext" ,libxext)
         ("libx11" ,libx11)))
@@ -5093,7 +5093,6 @@ over Xlib, including:
       `(("libpciaccess" ,libpciaccess)
         ("mesa" ,mesa)
         ("pixman" ,pixman)
-        ("xineramaproto" ,xineramaproto)
         ("xorgproto" ,xorgproto)))
     (inputs
       `(("udev" ,eudev)