summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-01-16 21:07:31 +0100
committerLudovic Courtès <ludo@gnu.org>2015-01-16 21:11:55 +0100
commite48977e755767232a3ce3f0dc3f9d44c735c5ffe (patch)
treee454a2f4ed85f0150c0e3fc3ee4a4d85ba364e12
parentf327b36edb1f754ddf5057959eaa26679e808687 (diff)
downloadguix-e48977e755767232a3ce3f0dc3f9d44c735c5ffe.tar.gz
gnu: e2fsck-static: Use really statically-linked executables.
* gnu/packages/linux.scm (e2fsprogs/static): New variable.
  (e2fsck/static): Use it in 'inputs'.
-rw-r--r--gnu/packages/linux.scm13
1 files changed, 12 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index f8bb6e2c1f..4973b27f62 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -562,6 +562,17 @@ slabtop, and skill.")
                    lgpl2.0                        ; libext2fs
                    x11))))                        ; libuuid
 
+(define e2fsprogs/static
+  (static-package
+   (package (inherit e2fsprogs)
+            (arguments
+             ;; Do not build shared libraries.
+             (substitute-keyword-arguments (package-arguments e2fsprogs)
+               ((#:configure-flags _)
+                '(list "--disable-blkid"))
+               ((#:make-flags _)
+                '(list)))))))
+
 (define-public e2fsck/static
   (package
     (name "e2fsck-static")
@@ -587,7 +598,7 @@ slabtop, and skill.")
                          (remove-store-references file)
                          (chmod file #o555))
                        (scandir source (cut string-prefix? "fsck." <>))))))))
-    (inputs `(("e2fsprogs" ,(static-package e2fsprogs))))
+    (inputs `(("e2fsprogs" ,e2fsprogs/static)))
     (synopsis "Statically-linked fsck.* commands from e2fsprogs")
     (description
      "This package provides statically-linked command of fsck.ext[234] taken