summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-02-15 23:59:51 +0100
committerMarius Bakke <mbakke@fastmail.com>2017-02-19 01:19:33 +0100
commit2c1cad7ad2f95685be889bdf662ffdf8df87d5cf (patch)
tree4cb53e214695493061dccd2df14e5a65db460ca2
parentd296d30013587722b37aeb0be114e00b15564f3f (diff)
downloadguix-2c1cad7ad2f95685be889bdf662ffdf8df87d5cf.tar.gz
gnu: python-flake8-polyfill: Enable tests.
* gnu/packages/python.scm (python-flake8-polyfill,
python2-flake8-polyfill)[native-inputs]: Add PYTHON-FLAKE8, PYTHON-MOCK,
PYTHON-PYCODESTYLE and PYTHON-PYTEST. New field.
[arguments]: Replace 'check' phase with custom command.
-rw-r--r--gnu/packages/python.scm14
1 files changed, 14 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 635feb489c..89d8c5cb06 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6250,6 +6250,20 @@ complexity of Python source code.")
         (base32
          "02gn2wxvh9vnf7m7dld7ca4l60mg5c370hv3swwppkngwaqmcw67"))))
     (build-system python-build-system)
+    (arguments
+     '(#:phases
+       (modify-phases %standard-phases
+         (replace 'check
+           (lambda _
+             (setenv "PYTHONPATH"
+                     (string-append (getcwd) "/build/lib:"
+                                    (getenv "PYTHONPATH")))
+             (zero? (system* "py.test" "-v")))))))
+    (native-inputs
+     `(("python-flake8" ,python-flake8)
+       ("python-mock" ,python-mock)
+       ("python-pycodestyle" ,python-pycodestyle)
+       ("python-pytest" ,python-pytest)))
     (home-page "https://gitlab.com/pycqa/flake8-polyfill")
     (synopsis "Polyfill package for Flake8 plugins")
     (description