summary refs log tree commit diff
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2020-01-19 18:07:27 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2020-03-19 11:36:19 +0100
commit49e247efccb46a9808a2662489857ec9f0fb6664 (patch)
treede808ed6e2be6771a8677380ce22518bc7626b2e
parent7a0bb02db42585c8670170bb1a73f6efda155f66 (diff)
downloadguix-49e247efccb46a9808a2662489857ec9f0fb6664.tar.gz
gnu: Add kdav.
This is in kde-pim.scm since it explicitly offers the "KPimKDAV".

* gnu/package/kde-pim.scm (kdav): New variable.
-rw-r--r--gnu/packages/kde-pim.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/kde-pim.scm b/gnu/packages/kde-pim.scm
index 1fb281e1ea..755cf316c5 100644
--- a/gnu/packages/kde-pim.scm
+++ b/gnu/packages/kde-pim.scm
@@ -449,6 +449,34 @@ data")
 functions for accessing calendar data using the kcalcore API.")
     (license  license:lgpl2.0+)))
 
+(define-public kdav
+  (package
+    (name "kdav")
+    (version "19.08.3")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/applications/" version
+                           "/src/kdav-" version ".tar.xz"))
+       (sha256
+        (base32 "1w59n17lridglphnm4mnmmzq1ijpbp269qxfmz01vk6wry6hlnp8"))))
+    (build-system qt-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)))
+    (inputs
+     `(("kcoreaddons" ,kcoreaddons)
+       ("ki18n" ,ki18n)
+       ("kio" ,kio)
+       ("qtbase" ,qtbase)
+       ("qtxmlpatterns" ,qtxmlpatterns)))
+    (home-page "https://cgit.kde.org/kdav.git")
+    (synopsis "DAV protocol implementation with KJobs")
+    (description "This is a DAV protocol implemention with KJobs.  Calendars
+and todos are supported, using either GroupDAV or CalDAV, and contacts are
+supported using GroupDAV or CardDAV.")
+    (license ;; GPL for programs, LGPL for libraries
+     (list license:gpl2+ license:lgpl2.0+))))
+
 (define-public kdepim-apps-libs
   (package
     (name "kdepim-apps-libs")