summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-11-16 23:05:49 +0100
committerLudovic Courtès <ludo@gnu.org>2020-11-16 23:41:02 +0100
commit37c21b130c0072f23bb735ca6903d8711416d5d9 (patch)
treeedd463a45e1732624b687bb67e624e29f82708b8
parent6cad3f6966e056c4d8a32cb85446040f56929c50 (diff)
downloadguix-37c21b130c0072f23bb735ca6903d8711416d5d9.tar.gz
gnu: guix: Use libexec/guix/guile in the 'guix' shebang.
This is a followup to 880fe019ae64df37815bbdb1a22305f99dae759d.

* gnu/packages/package-management.scm (guix)[arguments]: Delete
'patch-shebangs' phase.
-rw-r--r--gnu/packages/package-management.scm8
1 files changed, 7 insertions, 1 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 86e3f2bf00..512f1950a3 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -336,7 +336,13 @@ $(prefix)/etc/init.d\n")))
                             (let ((bash (assoc-ref inputs "bash")))
                               (substitute* (string-append out "/bin/guix")
                                 (("^#!.*/bash") (string-append "#! " bash "/bin/bash")))))
-                          #t))))))
+                          #t)))
+
+                    ;; The 'guix' executable has 'OUT/libexec/guix/guile' has
+                    ;; its shebang; that should remain unchanged, thus remove
+                    ;; the 'patch-shebangs' phase, which would otherwise
+                    ;; change it to 'GUILE/bin/guile'.
+                    (delete 'patch-shebangs))))
       (native-inputs `(("pkg-config" ,pkg-config)
 
                        ;; Guile libraries are needed here for