summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-05-28 22:36:31 -0400
committerMark H Weaver <mhw@netris.org>2015-05-29 14:33:32 -0400
commit86e3e370e389fa3b7decdf34e44b42bcc462554d (patch)
tree693876f5c959ef32711cc3573a52808e968a636c
parentae0bcc1e9d43fe961224ef564a36d2ec564271b6 (diff)
downloadguix-86e3e370e389fa3b7decdf34e44b42bcc462554d.tar.gz
gnu: nss: Update to 3.19.1.
* gnu/packages/gnuzilla.scm (nss): Update to 3.19.1.
  [properties]: Set the timeout to 40 hours.
-rw-r--r--gnu/packages/gnuzilla.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 20930c302a..2450a1e68a 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -124,7 +124,7 @@ in the Mozilla clients.")
 (define-public nss
   (package
     (name "nss")
-    (version "3.18")
+    (version "3.19.1")
     (source (origin
               (method url-fetch)
               (uri (let ((version-with-underscores
@@ -135,7 +135,7 @@ in the Mozilla clients.")
                       "nss-" version ".tar.gz")))
               (sha256
                (base32
-                "0h0xy9kvd2s8r438q4dfn25cgvv5dc1hkm9lb4bgrxpr5bxv13b1"))
+                "1zrgqlli01gsg2a5w4bk2p0q3aagi5dhd31yirnj04zca6ap1gmp"))
               ;; Create nss.pc and nss-config.
               (patches (list (search-patch "nss-pkgconfig.patch")))))
     (build-system gnu-build-system)
@@ -205,6 +205,12 @@ in the Mozilla clients.")
        ("zlib" ,zlib)))
     (propagated-inputs `(("nspr" ,nspr))) ; required by nss.pc.
     (native-inputs `(("perl" ,perl)))
+
+    ;; The NSS test suite takes over 28 hours on Loongson 3A (MIPS), and
+    ;; possibly longer when another build is happening concurrently on the
+    ;; same machine.
+    (properties '((timeout . 144000)))  ; 40 hours
+
     (home-page
      "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS")
     (synopsis "Network Security Services")