summary refs log tree commit diff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-09-09 00:26:26 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-09-14 00:14:53 +0200
commit8c692a52586937a58627ae609f08aaabb102b64f (patch)
tree199ab19af95b7f93dc7e1be7085e2879629e3687
parented56af06bc9ecc240f5334df26ebca679fbabd00 (diff)
downloadguix-8c692a52586937a58627ae609f08aaabb102b64f.tar.gz
gnu: Add python-wrapt
* gnu/packages/python.scm (python-wrapt, python2-wrapt): New variables.
-rw-r--r--gnu/packages/python.scm32
1 files changed, 32 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f85c788f43..04c842bc83 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4767,3 +4767,35 @@ and MAC network addresses.")
 
 (define-public python2-netaddr
   (package-with-python2 python-netaddr))
+
+(define-public python-wrapt
+  (package
+    (name "python-wrapt")
+    (version "1.10.5")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append
+               "https://pypi.python.org/packages/source/w/wrapt/wrapt-"
+               version
+               ".tar.gz"))
+        (sha256
+          (base32
+            "0cq8rlpzkxzk48b50yrfhzn1d1hrq4gjcdqlrgq4v5palgiv9jwr"))))
+    (build-system python-build-system)
+    (arguments
+     ;; Tests are not included in the tarball, they are only available in the
+     ;; git repository.
+     `(#:tests? #f))
+    (inputs
+      `(("python-setuptools" ,python-setuptools)))
+    (home-page "https://github.com/GrahamDumpleton/wrapt")
+    (synopsis "Module for decorators, wrappers and monkey patching")
+    (description
+      "The aim of the wrapt module is to provide a transparent object proxy for
+  Python, which can be used as the basis for the construction of function
+  wrappers and decorator functions.")
+    (license bsd-2)))
+
+(define-public python2-wrapt
+  (package-with-python2 python-wrapt))