summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-15 22:41:42 -0400
committerLeo Famulari <leo@famulari.name>2016-10-15 22:43:41 -0400
commita39cc016329f1f490ac7629fa81c9b686e7b0f4e (patch)
tree6ce018042eec0dbf7e00c6f7d2d544fc80232cb4
parentca0eee9df5b048dbf509a91c3b78a805fd1e2200 (diff)
downloadguix-a39cc016329f1f490ac7629fa81c9b686e7b0f4e.tar.gz
gnu: python-ndg-httpsclient: Disable tests.
The tests were silently skipped with Python 3.4. With Python 3.5, this caused
the python-ndg-httpsclient build to fail.

* gnu/packages/python.scm (python-ndg-httpsclient)[arguments]: Disable tests.
-rw-r--r--gnu/packages/python.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index f6917ba86a..032530c69d 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -7088,6 +7088,9 @@ be set via config files and/or environment variables.")
                 (base32
                   "0x32ibixm3vv5m9xfk83xsqm8xcqw4dd0khbh6qbri6rxgymbhg8"))))
     (build-system python-build-system)
+    (arguments
+     '(;; The tests appear to require networking.
+       #:tests? #f))
     (propagated-inputs
      `(("python-pyopenssl" ,python-pyopenssl)))
     (synopsis "HTTPS support for Python's httplib and urllib2")