summary refs log tree commit diff
diff options
context:
space:
mode:
authorDavid Craven <david@craven.ch>2016-08-06 17:00:57 +0200
committerDavid Craven <david@craven.ch>2016-08-30 22:38:30 +0200
commitbdfe11a5e7802cbbe64cdf349b91355baa21883c (patch)
treedefef575773cf8d80c19bbf56da6b6ab52afc4a3
parent3e1ce65be61d322a295c3307ac94dd139d6addef (diff)
downloadguix-bdfe11a5e7802cbbe64cdf349b91355baa21883c.tar.gz
gnu: Add kglobalaccel.
* gnu/packages/kde-frameworks.scm (kglobalaccel): New variable.

Co-authored-by: Hartmut Goebel <h.goebel@crazy-compilers.com>
-rw-r--r--gnu/packages/kde-frameworks.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 449aeee1e1..673e53ab43 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -1926,3 +1926,44 @@ representation with images in HTML.  It supports setting different themes for
 emoticons coming from different providers.")
     ;; dual licensed, image files are licensed under cc-by-sa4.0
     (license (list license:gpl2+ license:lgpl2.1+ license:cc-by-sa4.0))))
+
+(define-public kglobalaccel
+  (package
+    (name "kglobalaccel")
+    (version "5.24.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://kde/stable/frameworks/"
+                           (version-major+minor version) "/"
+                           name "-" version ".tar.xz"))
+       (sha256
+        (base32
+         "123v0ld1q88hbm3d0mqgq6lcivfkqh7pbz4hb4n76ab5v43qc15c"))))
+    (build-system cmake-build-system)
+    (native-inputs
+     `(("extra-cmake-modules" ,extra-cmake-modules)
+       ("qttools" ,qttools)))
+    (inputs
+     `(("kconfig" ,kconfig)
+       ("kcrash" ,kcrash)
+       ("kcoreaddons" ,kcoreaddons)
+       ("kdbusaddons" ,kdbusaddons)
+       ("kwindowsystem" ,kwindowsystem)
+       ("libxcb" ,libxcb)
+       ("qtbase" ,qtbase)
+       ("qtx11extras" ,qtx11extras)
+       ("xcb-util-keysyms" ,xcb-util-keysyms)))
+    (arguments
+     `(#:phases
+       (modify-phases %standard-phases
+         (add-before 'check 'check-setup
+           (lambda _
+             (setenv "QT_QPA_PLATFORM" "offscreen")
+             #t)))))
+    (home-page "https://community.kde.org/Frameworks")
+    (synopsis "Global desktop keyboard shortcuts")
+    (description "KGlobalAccel allows you to have global accelerators that are
+independent of the focused window.  Unlike regular shortcuts, the application's
+window does not need focus for them to be activated.")
+    (license license:lgpl2.1+)))