summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2018-07-02 12:07:58 +0200
committerMarius Bakke <mbakke@fastmail.com>2018-07-02 12:07:58 +0200
commitcb4b508cd68df89bfbd5255a0c5569f8318ad50f (patch)
tree428e0ff8e56c9d72a97502531009d1fba03bf9a9
parentfa41a089a1713601648664242530a55b6f6b1d0c (diff)
downloadguix-cb4b508cd68df89bfbd5255a0c5569f8318ad50f.tar.gz
build-system/meson: Really skip the 'fix-runpath' phase on armhf.
This follows up commit d5b5a15a4046362377f1a45d466b43bb6e93d4f which doesn't
work because %current-system etc expands before the actual build.

Fixes <https://bugs.gnu.org/31719>.

* guix/build-system/meson.scm (meson-build)[builder]: Compare against the
already existing "system" variable rather than (%current-system).
-rw-r--r--guix/build-system/meson.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/guix/build-system/meson.scm b/guix/build-system/meson.scm
index 529a2b8b0f..e894e1472d 100644
--- a/guix/build-system/meson.scm
+++ b/guix/build-system/meson.scm
@@ -148,8 +148,7 @@ has a 'meson.build' file."
                     #:search-paths ',(map search-path-specification->sexp
                                           search-paths)
                     #:phases
-                    (if (string-prefix? "arm" ,(or (%current-target-system)
-                                                   (%current-system)))
+                    (if (string-prefix? "arm" ,system)
                         (modify-phases build-phases (delete 'fix-runpath))
                         build-phases)
                     #:configure-flags ,configure-flags