summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:47:11 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commit1e28085e76dffe0edf84e9e5c336f3c0d9890c73 (patch)
tree8fd5a5f643eb28facd4a5ba4dc20ac6ee1ea47ca
parentadd56f346991696b74cd6318dc7dfaa1e7fffba6 (diff)
downloadguix-1e28085e76dffe0edf84e9e5c336f3c0d9890c73.tar.gz
gnu: Add go-github-com-calmh-xdr.
* gnu/packages/syncthing.scm (go-github-com-calmh-xdr): New variable.
-rw-r--r--gnu/packages/syncthing.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ec995fff39..58c74bc8ce 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -92,3 +92,28 @@ the LZ4 compression algorithm.")
 information, such as how much storage space is available, free, and used.")
     (home-page "https://github.com/calmh/du")
     (license public-domain)))
+
+(define-public go-github-com-calmh-xdr
+  (let ((commit "08e072f9cb164f943a92eb59f90f3abc64ac6e8f")
+        (revision "0"))
+    (package
+      (name "go-github-com-calmh-xdr")
+      (version (git-version "2.0.1" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/calmh/xdr")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "072wqdncz3nd4a3zkhvzzx1y3in1lm29wfvl0d8wrnqs5pyqh0mh"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/calmh/xdr"))
+      (synopsis "XDR marshalling and unmarshalling")
+      (description "XDR is an External Data Representation (XDR)
+marshalling and unmarshalling library in Go.  It uses code generation and not
+reflection.")
+      (home-page "https://github.com/calmh/xdr")
+      (license expat))))