summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:58:18 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:46 -0400
commit340e1a9a2426f6947f119b87715e2092a805c9f3 (patch)
treec7204d5402afc95c87b9b955e785d30b62ecef0d
parent7577a1d520b8539e6c9e643de4d7dc51ef2c092f (diff)
downloadguix-340e1a9a2426f6947f119b87715e2092a805c9f3.tar.gz
gnu: Add go-github-com-lib-pq.
* gnu/packages/syncthing.scm (go-github-com-lib-pq): New variable.
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 878a51c5f9..0325a0f595 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -356,3 +356,30 @@ file that is running.  This can be used for upgrading the current executable or
 finding resources located relative to the executable file.")
       (home-page "https://github.com/kardianos/osext")
       (license bsd-3))))
+
+(define-public go-github-com-lib-pq
+  (let ((commit "2704adc878c21e1329f46f6e56a1c387d788ff94")
+        (revision "0"))
+    (package
+      (name "go-github-com-lib-pq")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/lib/pq")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "160fmvi7bczxw3i3h5s821hv029ph5ld8x3c36b4cz2sr30wp110"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/lib/pq"
+         ;; The tests seem to fail without access to the network or a running
+         ;; Postgres instance.
+         #:tests? #f))
+      (synopsis "Golang Postgres driver for Go's database/sql")
+      (description "This packages provides a pure Go Postgres driver for Go's
+database/sql package.")
+      (home-page "https://github.com/lib/pq")
+      (license expat))))