summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-12 12:28:23 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:57 -0500
commit40b2ea4c2cd506ba9f41c0d5f0c01523de95e261 (patch)
tree1bbe8fa6470843d762b0c93b211f454453a0e43a
parent1a17aa2dc7dedf4125517ff8532f20b7da73a0c9 (diff)
downloadguix-40b2ea4c2cd506ba9f41c0d5f0c01523de95e261.tar.gz
gnu: Add Carp-Clan.
* gnu/packages/perl.scm (perl-carp-clan): New variable.
-rw-r--r--gnu/packages/perl.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 96a77c95bf..2909029e6c 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -237,6 +237,29 @@ code or from an external program.  Optionally, output can be teed so that it
 is captured while being passed through to the original file handles.")
     (license asl2.0)))
 
+(define-public perl-carp-clan
+  (package
+    (name "perl-carp-clan")
+    (version "6.04")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/ST/STBEY/"
+                           "Carp-Clan-" version ".tar.gz"))
+       (sha256
+        (base32
+         "1v71k8s1pi16l5y579gnrg372c6pdvy6qqm6iddm8h1dx7n16bjl"))))
+    (build-system perl-build-system)
+    (native-inputs
+     `(("perl-test-exception" ,perl-test-exception)))
+    (home-page "http://search.cpan.org/dist/Carp-Clan")
+    (synopsis "Report errors from a \"clan\" of modules")
+    (description "This module allows errors from a clan (or family) of modules
+to appear to originate from the caller of the clan.  This is necessary in
+cases where the clan modules are not classes derived from each other, and thus
+the Carp.pm module doesn't help.")
+    (license (package-license perl))))
+
 (define-public perl-class-accessor
   (package
     (name "perl-class-accessor")