summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:43:08 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:44 -0400
commit67b468182acb7b59fac454349ad6225d043de079 (patch)
treed62f37f1c0f464dc6910596ac3a61a49472baca7
parent56a37713c3fada3010666278eb37873980746572 (diff)
downloadguix-67b468182acb7b59fac454349ad6225d043de079.tar.gz
gnu: Add go-github-com-bkaradzic-go-lz4.
* gnu/packages/syncthing.scm (go-github-com-bkaradzic-go-lz4): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index ac162d4e9a..225af85cfc 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -46,3 +46,27 @@ protocol for port mapping and discovering the external IP address of a
 firewall.")
       (home-page "https://github.com/AudriusButkevicius/go-nat-pmp")
       (license asl2.0))))
+
+(define-public go-github-com-bkaradzic-go-lz4
+  (let ((commit "7224d8d8f27ef618c0a95f1ae69dbb0488abc33a")
+        (revision "0"))
+    (package
+      (name "go-github-com-bkaradzic-go-lz4")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/bkaradzic/go-lz4")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                  (base32
+                    "10lmya17vdqg2pvqni0p73iahni48s1v11ya9a0hcz4jh5vw4dkb"))))
+      (build-system go-build-system)
+      (arguments
+        `(#:import-path "github.com/bkaradzic/go-lz4"))
+      (synopsis "LZ4 compression algorithm")
+      (description "This package provides @code{go-lz4}, a Go implementation of
+the LZ4 compression algorithm.")
+      (home-page "https://github.com/bkaradzic/go-lz4")
+      (license bsd-2))))