summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-07-27 17:51:38 -0400
committerLeo Famulari <leo@famulari.name>2017-07-30 20:10:40 -0400
commita4d6a95793b2c98fb11908d6dec85532d6df5613 (patch)
tree61d3e4deb74f14e6d121f976b03cd9692b5ca0a4
parent9ad78b2c21738e853986281a5051158fe39d8435 (diff)
downloadguix-a4d6a95793b2c98fb11908d6dec85532d6df5613.tar.gz
gnu: Add perl-test2-plugin-nowarnings.
* gnu/packages/perl.scm (perl-test2-plugin-nowarnings): New variable.
-rw-r--r--gnu/packages/perl.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 54f57a7cb7..26ff0458fb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -6501,6 +6501,28 @@ into tables.")
 etc built upon the Test2 testing library.")
     (license (package-license perl))))
 
+(define-public perl-test2-plugin-nowarnings
+  (package
+    (name "perl-test2-plugin-nowarnings")
+    (version "0.06")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (string-append "mirror://cpan/authors/id/D/DR/DROLSKY/Test2-Plugin-NoWarnings-"
+                            version ".tar.gz"))
+        (sha256
+         (base32
+          "002qk6qsm0l6r2kaxywvc38w0yf0mlavgywq8li076pn6kcw3242"))))
+    (build-system perl-build-system)
+    (propagated-inputs
+     `(("perl-test2-bundle-extended" ,perl-test2-bundle-extended)))
+    (home-page "http://search.cpan.org/dist/Test2-Plugin-NoWarnings/")
+    (synopsis "Fail if tests warn")
+    (description "Loading this plugin causes your tests to fail if there any
+warnings while they run.  Each warning generates a new failing test and the
+warning content is outputted via diag.")
+    (license (package-license perl))))
+
 (define-public perl-test-base
   (package
     (name "perl-test-base")