summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 00:47:45 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:45 -0400
commitab3e15899c6d37e7310e7403fdc72b2b4ae694fa (patch)
tree730960582683969eb52a3146a663b6f9600e2ac8
parent1e28085e76dffe0edf84e9e5c336f3c0d9890c73 (diff)
downloadguix-ab3e15899c6d37e7310e7403fdc72b2b4ae694fa.tar.gz
gnu: Add go-github-com-d4l3k-messagediff.
* gnu/packages/syncthing.scm (go-github-com-d4l3k-messagediff): New variable.
-rw-r--r--gnu/packages/syncthing.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 58c74bc8ce..4d1b2a86fe 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -117,3 +117,27 @@ marshalling and unmarshalling library in Go.  It uses code generation and not
 reflection.")
       (home-page "https://github.com/calmh/xdr")
       (license expat))))
+
+(define-public go-github-com-d4l3k-messagediff
+  (let ((commit "29f32d820d112dbd66e58492a6ffb7cc3106312b")
+        (revision "0"))
+    (package
+      (name "go-github-com-d4l3k-messagediff")
+      (version (git-version "1.1.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                       (url "https://github.com/d4l3k/messagediff")
+                       (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "104hl8x57ciaz7mzafg1vp9qggxcyfm8hsv9bmlihbz9ml3nyr8v"))))
+      (build-system go-build-system)
+      (arguments
+        `(#:import-path "github.com/d4l3k/messagediff"))
+      (synopsis "Diff arbitrary Go structs")
+      (description "Messagediff is a library for calculating diffs of arbitrary
+structs in the Go programming language.")
+      (home-page "https://github.com/d4l3k/messagediff")
+      (license expat))))