summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-02-27 14:40:21 +0100
committerLudovic Courtès <ludo@gnu.org>2015-02-27 15:08:37 +0100
commitda6dd842d038aa0761918305953ad92951fb663f (patch)
tree0f3642682b8768306b9ebb8c94d4abf790aaf23c
parente8c9f0498f9f3ead4ea345d49f1c5e630ff158f8 (diff)
downloadguix-da6dd842d038aa0761918305953ad92951fb663f.tar.gz
gnu: Remove now unneeded 'unpack' phases for unzip.
This is a followup to commit cd0385b.

* gnu/packages/bioinformatics.scm (hisat)[arguments]: Remove 'unpack'
  phase.
* gnu/packages/image.scm (freeimage): Likewise.
* gnu/packages/python.scm (python2-cssutils): Likewise.
-rw-r--r--gnu/packages/bioinformatics.scm53
-rw-r--r--gnu/packages/image.scm23
-rw-r--r--gnu/packages/python.scm10
3 files changed, 35 insertions, 51 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index b64dab73cd..dbafd94c2f 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -265,35 +265,30 @@ Illumina, Roche 454, and the SOLiD platform.")
                             '()
                             '("POPCNT_CAPABILITY=0")))
        #:phases
-       (alist-replace
-        'unpack
-        (lambda* (#:key source #:allow-other-keys)
-          (and (zero? (system* "unzip" source))
-               (chdir "hisat-0.1.4-beta")))
-        (alist-cons-after
-         'unpack 'patch-sources
-         (lambda _
-           ;; XXX Cannot use snippet because zip files are not supported
-           (substitute* "Makefile"
-             (("^CC = .*$") "CC = gcc")
-             (("^CPP = .*$") "CPP = g++")
-             ;; replace BUILD_HOST and BUILD_TIME for deterministic build
-             (("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
-             (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\""))
-           (substitute* '("hisat-build" "hisat-inspect")
-             (("/usr/bin/env") (which "env"))))
-         (alist-replace
-          'install
-          (lambda* (#:key outputs #:allow-other-keys)
-            (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
-              (mkdir-p bin)
-              (for-each
-               (lambda (file)
-                 (copy-file file (string-append bin file)))
-               (find-files
-                "."
-                "hisat(-(build|align|inspect)(-(s|l)(-debug)*)*)*$"))))
-          (alist-delete 'configure %standard-phases))))))
+       (alist-cons-after
+        'unpack 'patch-sources
+        (lambda _
+          ;; XXX Cannot use snippet because zip files are not supported
+          (substitute* "Makefile"
+            (("^CC = .*$") "CC = gcc")
+            (("^CPP = .*$") "CPP = g++")
+            ;; replace BUILD_HOST and BUILD_TIME for deterministic build
+            (("-DBUILD_HOST=.*") "-DBUILD_HOST=\"\\\"guix\\\"\"")
+            (("-DBUILD_TIME=.*") "-DBUILD_TIME=\"\\\"0\\\"\""))
+          (substitute* '("hisat-build" "hisat-inspect")
+            (("/usr/bin/env") (which "env"))))
+        (alist-replace
+         'install
+         (lambda* (#:key outputs #:allow-other-keys)
+           (let ((bin (string-append (assoc-ref outputs "out") "/bin/")))
+             (mkdir-p bin)
+             (for-each
+              (lambda (file)
+                (copy-file file (string-append bin file)))
+              (find-files
+               "."
+               "hisat(-(build|align|inspect)(-(s|l)(-debug)*)*)*$"))))
+         (alist-delete 'configure %standard-phases)))))
     (native-inputs
      `(("unzip" ,unzip)))
     (inputs
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index a71465dc12..46b0824c8d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -385,20 +385,15 @@ supplies a generic doubly-linked list and some string functions.")
               "0q1gnjnxgphsh4l8i9rfly4bi8xsczsb9ryzbm8hf38lc3fk5bq3"))))
    (build-system gnu-build-system)
    (arguments
-    '(#:phases (alist-replace
-                'unpack
-                (lambda* (#:key source #:allow-other-keys)
-                  (and (zero? (system* "unzip" source))
-                       (chdir "FreeImage")))
-                (alist-delete
-                 'configure
-                 (alist-cons-before
-                  'build 'patch-makefile
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    (substitute* "Makefile.gnu"
-                      (("/usr") (assoc-ref outputs "out"))
-                      (("-o root -g root") "")))
-                  %standard-phases)))
+    '(#:phases (alist-delete
+                'configure
+                (alist-cons-before
+                 'build 'patch-makefile
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "Makefile.gnu"
+                     (("/usr") (assoc-ref outputs "out"))
+                     (("-o root -g root") "")))
+                 %standard-phases))
       #:make-flags '("CC=gcc")
       #:tests? #f)) ; no check target
    (native-inputs
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index bbff241833..0df91d69cb 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Nikita Karetnikov <nikita@karetnikov.org>
-;;; Copyright © 2013, 2014 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2014 Eric Bavier <bavier@member.fsf.org>
@@ -3129,13 +3129,7 @@ capabilities to the Python interpreter.")
     (arguments
      `(#:python ,python-2 ; Otherwise tests fail with a syntax error.
        #:tests? #f ; The tests apparently download an external URL.
-       #:phases
-       (alist-replace
-        'unpack
-        (lambda* (#:key source #:allow-other-keys)
-          (and (zero? (system* "unzip" source))
-               (chdir "cssutils-1.0")))
-        %standard-phases)))
+       ))
     (home-page "http://cthedot.de/cssutils/")
     (synopsis
       "CSS Cascading Style Sheets library for Python")