summary refs log tree commit diff
diff options
context:
space:
mode:
authorEric Bavier <bavier@member.fsf.org>2015-03-11 16:44:20 -0500
committerEric Bavier <bavier@member.fsf.org>2015-03-12 15:55:56 -0500
commitfcf1043e565fa72fcec8a58c866d69994d1084ca (patch)
treeef1fda23e2be333194e5335ace7ccda694d74c75
parent4abba47dc6d3aacd17226b8f85645672a172f59a (diff)
downloadguix-fcf1043e565fa72fcec8a58c866d69994d1084ca.tar.gz
gnu: Add Class-Date.
* gnu/packages/perl.scm (perl-class-date): New variable.
-rw-r--r--gnu/packages/perl.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 15e28eb70a..619d2edafb 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -240,6 +240,26 @@ whole (instead of about a single object).  This data is then inherited by your
 subclasses and can be overriden.")
     (license (package-license perl))))
 
+(define-public perl-class-date
+  (package
+    (name "perl-class-date")
+    (version "1.1.15")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cpan/authors/id/S/SZ/SZABGAB/"
+                           "Class-Date-" version ".tar.gz"))
+       (sha256
+        (base32
+         "0dd707sq8ix2dqbnp7ga77ba69r3vsn0cd6scnkn13s0gm2g4b00"))))
+    (build-system perl-build-system)
+    (arguments `(#:tests? #f))          ;timezone tests in chroot
+    (home-page "http://search.cpan.org/dist/Class-Date")
+    (synopsis "Class for easy date and time manipulation")
+    (description "This module provides a general-purpose date and datetime
+type for perl.")
+    (license (package-license perl))))
+
 (define-public perl-class-inspector
   (package
     (name "perl-class-inspector")