summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-10-11 19:59:26 -0400
committerLeo Famulari <leo@famulari.name>2017-10-12 21:22:48 -0400
commit292a6b0d16e19a5cb960053d6da631754b1b5795 (patch)
tree5c7e09eec62c085f34fcf74b8d13aa9bd26dcec2
parentf7612f0fcfaf675ef466691efbba77317143171f (diff)
downloadguix-292a6b0d16e19a5cb960053d6da631754b1b5795.tar.gz
gnu: Add go-github-com-vitrun-qart-coding.
* gnu/packages/syncthing.scm (go-github-com-vitrun-qart-coding): New variable.
-rw-r--r--gnu/packages/syncthing.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 1b48ca96ea..d1471075d2 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -600,6 +600,36 @@ environment")
       (home-page "https://github.com/thejerf/suture")
       (license expat))))
 
+(define-public go-github-com-vitrun-qart-coding
+  (let ((commit "bf64b92db6b05651d6c25a3dabf2d543b360c0aa")
+        (revision "0"))
+    (package
+      (name "go-github-com-vitrun-qart-coding")
+      (version (git-version "0.0.0" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/vitrun/qart")
+                      (commit commit)))
+                (file-name (string-append "go-github-com-vitrun-qart-"
+                                          version "-checkout"))
+                (sha256
+                 (base32
+                  "1xk7qki703xmay9ghi3kq2bjf1iw9dz8wik55739d6i7sn77vvkc"))))
+      (build-system go-build-system)
+      (arguments
+       `(#:import-path "github.com/vitrun/qart/coding"
+         #:unpack-path "github.com/vitrun/qart"))
+      (synopsis "Low-level QR coding library")
+      (description "This package provides a library for embedding
+human-meaningful graphics in QR codes.  However, instead of scribbling on
+redundant pieces and relying on error correction to preserve the meaning,
+@code{qart} engineers the encoded values to create the picture in a code with no
+inherent errors.  This @code{qart} component, @code{coding}, implements
+low-level QR coding details.")
+      (home-page "https://github.com/vitrun/qart/")
+      (license bsd-3))))
+
 (define-public go-golang-org-x-sys-unix
   (let ((commit "f3918c30c5c2cb527c0b071a27c35120a6c0719a")
         (revision "0"))