summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-10-25 05:15:47 +0200
committerRicardo Wurmus <rekado@elephly.net>2018-10-25 05:17:42 +0200
commit55a08dceb5c1522dcbcb2c49a2ca8f261abe8747 (patch)
treeb889416d27fa8a162ea7d826b056d7257da0f176
parent7753b5436687bdf913439d1ab74b13b0b39b630b (diff)
downloadguix-55a08dceb5c1522dcbcb2c49a2ca8f261abe8747.tar.gz
gnu: Add r-emmeans.
* gnu/packages/cran.scm (r-emmeans): New variable.
-rw-r--r--gnu/packages/cran.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 361140c822..b89a477fbd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -6350,3 +6350,30 @@ mixed effects, and survival models.  The package includes demos reproducing
 analyzes presented in the book \"Multiple Comparisons Using R\" (Bretz,
 Hothorn, Westfall, 2010, CRC Press).")
     (license license:gpl2)))
+
+(define-public r-emmeans
+  (package
+    (name "r-emmeans")
+    (version "1.2.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "emmeans" version))
+       (sha256
+        (base32
+         "01g6albv9whpdsj4j7c3q02pwdlkscjl5d2l8z96qafw7n9gml6g"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-estimability" ,r-estimability)
+       ("r-mvtnorm" ,r-mvtnorm)
+       ("r-plyr" ,r-plyr)
+       ("r-xtable" ,r-xtable)))
+    (home-page "https://github.com/rvlenth/emmeans")
+    (synopsis "Estimated marginal means, aka least-squares means")
+    (description
+     "This package provides tools to obtain @dfn{estimated marginal
+means} (EMMs) for many linear, generalized linear, and mixed models.  It can
+be used to compute contrasts or linear functions of EMMs, trends, and
+comparisons of slopes.")
+    ;; Either version of the license.
+    (license (list license:gpl2 license:gpl3))))