summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-06-19 19:59:10 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-06-20 04:56:38 +0200
commit80f755090db5d67af5a44992d11799cb65792c3e (patch)
tree2a67e0a256044841d3efbeee8fdb5f587086cc68
parentbdf1fe51d53409e3d0991cc54cba53184f191bf2 (diff)
downloadguix-80f755090db5d67af5a44992d11799cb65792c3e.tar.gz
gnu: perl-lwp-protocol-https: Update to 6.07.
* gnu/packages/web.scm (perl-lwp-protocol-https): Update to 6.07.
[native-inputs]: Add perl-test-requiresinternet.
-rw-r--r--gnu/packages/web.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index aaf8505ef4..2319acb3ca 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3089,16 +3089,19 @@ exists it is used instead.")
 (define-public perl-lwp-protocol-https
   (package
     (name "perl-lwp-protocol-https")
-    (version "6.06")
+    (version "6.07")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append "mirror://cpan/authors/id/M/MS/MSCHILLI/"
+       (uri (string-append "mirror://cpan/authors/id/O/OA/OALDERS/"
                            "LWP-Protocol-https-" version ".tar.gz"))
        (sha256
         (base32
-         "1vxdjqj4bwq56m9h1bqqwkk3c6jr76f2zqzvwa26yjng3p686v5q"))))
+         "1rxrpwylfw1afah0nk96kgkwjbl2p1a7lwx50iipg8c4rx3cjb2j"))))
     (build-system perl-build-system)
+    (native-inputs
+     ;; For tests.
+     `(("perl-test-requiresinternet" ,perl-test-requiresinternet)))
     (propagated-inputs
      `(("perl-io-socket-ssl" ,perl-io-socket-ssl)
        ("perl-libwww" ,perl-libwww)