summary refs log tree commit diff
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-10-25 04:20:27 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-10-25 04:59:32 +0200
commit95f6adae34e81513b878ecd8c98c1b21c217a2b6 (patch)
tree3abd2f01970192a84fb1d0dcbfc222fbf347d25b
parentb865e7c254ac55002e86e3b8df7edeb73ffeac0d (diff)
downloadguix-95f6adae34e81513b878ecd8c98c1b21c217a2b6.tar.gz
gnu: sfml: Don't use unstable tarball.
* gnu/packages/game-development.scm (sfml)[source]: Use GIT-FETCH and
GIT-FILE-NAME.
-rw-r--r--gnu/packages/game-development.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 6b7e71f6c0..6ed14083b0 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -442,16 +442,17 @@ clone.")
     (name "sfml")
     (version "2.5.0")
     (source (origin
-              (method url-fetch)
+              (method git-fetch)
               ;; Do not fetch the archives from
               ;; http://mirror0.sfml-dev.org/files/ because files there seem
               ;; to be changed in place.
-              (uri (string-append "https://github.com/SFML/SFML/archive/"
-                                  version ".tar.gz"))
-              (file-name (string-append name "-" version ".tar.gz"))
+              (uri (git-reference
+                    (url "https://github.com/SFML/SFML.git")
+                    (commit version)))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "1x3yvhdrln5b6h4g5r4mds76gq8zsxw6icxqpwqkmxsqcq5yviab"))
+                "1cmg7xgk2shi94h47w0p9g0wh4g00sgwlq0nwc1n6d6qy9wfrx1k"))
               (modules '((guix build utils)))
               (snippet
                '(begin