summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-10-07 15:16:24 +0200
committerLudovic Courtès <ludo@gnu.org>2022-10-07 16:01:39 +0200
commita52f39ad0c0ffe78e4d2eef5fefdb4204799fdcb (patch)
tree991f5544405b5a59f7a2f002ccce30c838e83717
parentf9694a04abf2ee40c8428d3afd577774557e9926 (diff)
downloadguix-a52f39ad0c0ffe78e4d2eef5fefdb4204799fdcb.tar.gz
gnu: rest@0.9.1: Remove dependency on gtksourceview and libadwaita.
Partly fixes <https://issues.guix.gnu.org/58352>.

This also reduces the closure size of rest@0.9.1 from 2.1GiB to
498MiB (on x86_64-linux).

* gnu/packages/gnome.scm (rest-next)[arguments]: Pass the
"-Dexamples=false" config flag.
* gnu/packages/gnome.scm (rest-next)[inputs]: Remove GTKSOURCEVIEW and
LIBADWAITA.
-rw-r--r--gnu/packages/gnome.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 7182822a4f..8043eec30d 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -4995,7 +4995,10 @@ libxml to ease remote use of the RESTful API.")
     (arguments (substitute-keyword-arguments (package-arguments rest)
                  ((#:tests? _ #f) #t)
                  ((#:configure-flags _)
-                  #~(list))
+                  ;; Do not build the optional 'librest-demo' program as it
+                  ;; depends on gtksourceview and libadwaita and thus,
+                  ;; indirectly, on Rust.
+                  #~(list "-Dexamples=false"))
                  ((#:phases phases '%standard-phases)
                   #~(modify-phases #$phases
                       (add-after 'unpack 'disable-problematic-tests
@@ -5012,7 +5015,7 @@ libxml to ease remote use of the RESTful API.")
        (append gettext-minimal
                gi-docgen
                gsettings-desktop-schemas)))
-    (inputs (list gtksourceview json-glib libadwaita))
+    (inputs (list json-glib))
     (propagated-inputs
      (modify-inputs (package-propagated-inputs rest)
        (replace "libsoup" libsoup)