summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-10-23 09:43:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-10-23 10:30:58 +0300
commitb249da1ddf78366002b45ef3e748156617301526 (patch)
treec1ea3ef8ff2ef9cea5421a6d8309a9df1b066c5b
parentc5050528ea7c52daad7697afa538a954163e5ec1 (diff)
downloadguix-b249da1ddf78366002b45ef3e748156617301526.tar.gz
gnu: Add rust-bitflags-1.1.
* gnu/packages/rust-cbindgen.scm (rust-bitflags-1.1): New hidden
variable.
-rw-r--r--gnu/packages/rust-cbindgen.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/rust-cbindgen.scm b/gnu/packages/rust-cbindgen.scm
index 35bc6b04df..6cc5882007 100644
--- a/gnu/packages/rust-cbindgen.scm
+++ b/gnu/packages/rust-cbindgen.scm
@@ -85,3 +85,24 @@ support.")
     (properties '((hidden? . #t)))
     (license (list license:asl2.0
                    license:expat))))
+
+(define rust-bitflags-1.1
+  (package
+    (name "rust-bitflags")
+    (version "1.1.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "bitflags" version))
+        (file-name (string-append name "-" version ".crate"))
+        (sha256
+         (base32
+          "1zc1qb1hwsnl2d8rhzicsv9kqd5b2hwbrscrcfw5as4sfr35659x"))))
+    (build-system cargo-build-system)
+    (home-page "https://github.com/bitflags/bitflags")
+    (synopsis "Macro to generate structures which behave like bitflags")
+    (description "This package provides a macro to generate structures which
+behave like a set of bitflags.")
+    (properties '((hidden? . #t)))
+    (license (list license:asl2.0
+                   license:expat))))