summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2019-11-05 01:54:41 -0500
committerTimothy Sample <samplet@ngyro.com>2019-11-20 20:48:31 -0500
commite924e17e4a4ee91265f5804326c23a7e41edc689 (patch)
tree2f51f39bde4e4e5351c6d991a78d81fb5daba637
parentfaac56f3af797973c4a8400d841bbddc303e924b (diff)
downloadguix-e924e17e4a4ee91265f5804326c23a7e41edc689.tar.gz
gnu: Add ghc-dense-linear-algebra.
* gnu/packages/haskell-xyz.scm (ghc-dense-linear-algebra): New variable.
-rw-r--r--gnu/packages/haskell-xyz.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell-xyz.scm b/gnu/packages/haskell-xyz.scm
index 604c2deaa9..035b9636bb 100644
--- a/gnu/packages/haskell-xyz.scm
+++ b/gnu/packages/haskell-xyz.scm
@@ -2566,6 +2566,36 @@ It includes hashing functions for all basic Haskell98 types.")
 providing an @code{rnf} implementation.")
     (license license:bsd-3)))
 
+(define-public ghc-dense-linear-algebra
+  (package
+    (name "ghc-dense-linear-algebra")
+    (version "0.1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://hackage.haskell.org/package/"
+                           "dense-linear-algebra/dense-linear-algebra-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "1m7jjxahqxj7ilic3r9806mwp5rnnsmn8vvipkmk40xl65wplxzp"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-math-functions" ,ghc-math-functions)
+       ("ghc-primitive" ,ghc-primitive)
+       ("ghc-vector" ,ghc-vector)
+       ("ghc-vector-algorithms" ,ghc-vector-algorithms)
+       ("ghc-vector-th-unbox" ,ghc-vector-th-unbox)
+       ("ghc-vector-binary-instances" ,ghc-vector-binary-instances)))
+    (native-inputs
+     `(("ghc-hspec" ,ghc-hspec)
+       ("ghc-quickcheck" ,ghc-quickcheck)))
+    (home-page "http://hackage.haskell.org/package/dense-linear-algebra")
+    (synopsis "Simple and incomplete implementation of linear algebra")
+    (description "This library is simply a collection of linear-algebra
+related modules split from the statistics library.")
+    (license license:bsd-2)))
+
 (define-public ghc-descriptive
   (package
     (name "ghc-descriptive")