summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-06-22 12:45:27 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-06-22 12:46:03 +0200
commitfae72ebb49c6cb3692c5f7bc9584fe66f7b90e51 (patch)
tree013eefd1642633a0725386b10acae305f687bb7e
parentd30ab75a7d74f9cddb29b3f87c214085a5dba3ac (diff)
downloadguix-fae72ebb49c6cb3692c5f7bc9584fe66f7b90e51.tar.gz
gnu: r-zoo: Move to (gnu packages cran).
* gnu/packages/statistics.scm (r-zoo): Move this variable from here...
* gnu/packages/cran.scm (r-zoo): ...to here.
-rw-r--r--gnu/packages/cran.scm20
-rw-r--r--gnu/packages/statistics.scm20
2 files changed, 20 insertions, 20 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 53b2338a06..bd347827c8 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -193,6 +193,26 @@ programming packages such as @code{knitr} and @code{rmarkdown}.")
 the system clipboards.")
     (license license:gpl3)))
 
+(define-public r-zoo
+  (package
+    (name "r-zoo")
+    (version "1.8-8")
+    (source (origin
+              (method url-fetch)
+              (uri (cran-uri "zoo" version))
+              (sha256
+               (base32
+                "1rrw431jwaxd9xljp73f15rhcxvwc0xlyrmr0ghi5fj7a03c932f"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-lattice" ,r-lattice)))
+    (home-page "http://zoo.R-Forge.R-project.org/")
+    (synopsis "S3 infrastructure for regular and irregular time series")
+    (description "This package contains an S3 class with methods for totally
+ordered indexed observations.  It is particularly aimed at irregular time
+series of numeric vectors/matrices and factors.")
+    (license license:gpl2+)))
+
 (define-public r-ggpmisc
   (package
     (name "r-ggpmisc")
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 91734cd449..40602339a8 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4281,26 +4281,6 @@ plot can be quickly adjusted using a flexible parameter dispatching
 mechanism.")
     (license license:gpl2+)))
 
-(define-public r-zoo
-  (package
-    (name "r-zoo")
-    (version "1.8-8")
-    (source (origin
-              (method url-fetch)
-              (uri (cran-uri "zoo" version))
-              (sha256
-               (base32
-                "1rrw431jwaxd9xljp73f15rhcxvwc0xlyrmr0ghi5fj7a03c932f"))))
-    (build-system r-build-system)
-    (propagated-inputs
-     `(("r-lattice" ,r-lattice)))
-    (home-page "http://zoo.R-Forge.R-project.org/")
-    (synopsis "S3 infrastructure for regular and irregular time series")
-    (description "This package contains an S3 class with methods for totally
-ordered indexed observations.  It is particularly aimed at irregular time
-series of numeric vectors/matrices and factors.")
-    (license license:gpl2+)))
-
 (define-public r-ztable
   (package
     (name "r-ztable")