summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2022-12-06 15:21:21 +0100
committerLudovic Courtès <ludo@gnu.org>2022-12-06 15:22:26 +0100
commitfe563a87ad7c171448c56ed6b628c8e32a52c94a (patch)
tree48b986f2a7792638c2fe537803862967614ac3d6
parent9ad14196ce48d5161fcaa7fc5fd26259e517cb30 (diff)
downloadguix-fe563a87ad7c171448c56ed6b628c8e32a52c94a.tar.gz
gnu: texinfo, info-reader: Do not run tests when cross-compiling.
Fixes a regression introduced in
a3264f31df9774ea514e18ed8e7b6bcb44061edc.

Reported by Mathieu Othacehe <othacehe@gnu.org>.

* gnu/packages/texinfo.scm (texinfo)[arguments]: Change #:tests? to not
run tests when cross-compiling.
-rw-r--r--gnu/packages/texinfo.scm3
1 files changed, 2 insertions, 1 deletions
diff --git a/gnu/packages/texinfo.scm b/gnu/packages/texinfo.scm
index 25498ae36e..7108d1e067 100644
--- a/gnu/packages/texinfo.scm
+++ b/gnu/packages/texinfo.scm
@@ -75,7 +75,8 @@
             %standard-phases)
 
        ;; XXX: Work around <https://issues.guix.gnu.org/59616>.
-       #:tests? ,(not (hurd-target?))))
+       #:tests? ,(and (not (hurd-target?))
+                      (not (%current-target-system)))))
     (inputs (list ncurses perl))
     ;; When cross-compiling, texinfo will build some of its own binaries with
     ;; the native compiler. This means ncurses is needed both in both inputs