summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <marius@devup.no>2020-05-27 15:07:31 +0200
committerMarius Bakke <marius@gnu.org>2020-05-27 21:49:56 +0200
commitfae1c86605046b3fbc93384170438382248faab3 (patch)
treec5e4b1f0ec10d5bc136f657d01c1157a5caad8fd
parentaf59d4b43d711c1033b16b0a94d7eaef3de770eb (diff)
downloadguix-fae1c86605046b3fbc93384170438382248faab3.tar.gz
gnu: Add ruby-mkmf-lite.
* gnu/packages/ruby.scm (ruby-mkmf-lite): New public variable.
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index cb9495a266..2ab6dc2394 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2839,6 +2839,28 @@ objects.")
     (home-page "https://github.com/floehopper/metaclass")
     (license license:expat)))
 
+(define-public ruby-mkmf-lite
+  (package
+    (name "ruby-mkmf-lite")
+    (version "0.3.2")
+    (source (origin
+              (method url-fetch)
+              (uri (rubygems-uri "mkmf-lite" version))
+              (sha256
+               (base32
+                "0br9k6zijj1zc25n8p7f2j1mwl58nfgdknf3q13h9k156jvrir06"))))
+    (build-system ruby-build-system)
+    (propagated-inputs
+     `(("ruby-ptools" ,ruby-ptools)))
+    (synopsis "Lightweight alternative to @code{mkmf}")
+    (description
+     "@code{mkmf-lite} is a light version of Ruby's @code{mkmf.rb} designed
+for use as a library.  It does not create packages, builds, or log files of
+any kind.  Instead, it provides mixin methods that you can use in FFI or tests
+to check for the presence of header files, constants, and so on.")
+    (home-page "https://github.com/djberg96/mkmf-lite")
+    (license license:asl2.0)))
+
 (define-public ruby-mspec
   (package
     (name "ruby-mspec")