summary refs log tree commit diff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-12-16 11:50:22 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-18 22:59:58 +0200
commit579e3712b0d7341804d76cc212c9edc28f64817c (patch)
tree6be508f6e4b79b44def0e2784538fe720c368bb4
parented906c84c72e4adc14cfbeea734171e177510877 (diff)
downloadguix-579e3712b0d7341804d76cc212c9edc28f64817c.tar.gz
gnu: commencement: gash-boot: Build fix for ARM.
* gnu/packages/commencement.scm (gash-boot)[arguments]: Add 'patch-compat
stage.
-rw-r--r--gnu/packages/commencement.scm13
1 files changed, 13 insertions, 0 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 9d6ed5fd08..5222d9e88a 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -157,6 +157,19 @@ pure Scheme to Tar and decompression in one easy step.")
            (replace 'configure
              (bootstrap-configure "Gash" ,(package-version gash)
                                   '("gash") "scripts"))
+           ;; ARM's %bootstrap-guile (2.0.11) does not have EXIT_SUCCESS.
+           (add-after 'unpack 'patch-compat
+             (lambda* _
+               (substitute* "gash/compat.scm"
+                 (("exact-integer") "avoid-exact-integer-override-in-2.0.11")
+                 (("\\(if-guile-version-below \\(2 0 10\\)")
+"(if-guile-version-below (2 0 10)
+  (begin
+    (define-public (exact-integer? x)
+      (and (integer? x) (exact? x)))))
+
+(if-guile-version-below (2 0 12)
+"))))
            (replace 'build (bootstrap-build '("gash")))
            (replace 'install (bootstrap-install '("gash") "scripts"))
            (add-after 'install 'install-symlinks