summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-07-01 17:40:47 -0400
committerLeo Famulari <leo@famulari.name>2016-07-03 22:24:45 -0400
commit5ebd95202c4578d29d13a35a2563c20609988f42 (patch)
treeb297eeb84960787f34f9017691dd6b53c30e8771
parent936984b421eebdfcd5870599d5cad9dab2d3b297 (diff)
downloadguix-5ebd95202c4578d29d13a35a2563c20609988f42.tar.gz
gnu: python-sphinx: Update to 1.4.4.
* gnu/packages/python.scm (python-sphinx, python2-sphinx): Update to 1.4.4.
[source]: Use pypi-uri.
[inputs]: Add python-alabaster, python-babel, python-imagesize, python-six.
[propagated-inputs]: New field.
-rw-r--r--gnu/packages/python.scm27
1 files changed, 19 insertions, 8 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 4479dddb2d..e9020c1f7e 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -2677,22 +2677,33 @@ reStructuredText.")
 (define-public python-sphinx
   (package
     (name "python-sphinx")
-    (version "1.2.3")
+    (version "1.4.4")
     (source
      (origin
        (method url-fetch)
-       (uri (string-append
-             "https://pypi.python.org/packages/source/S/Sphinx/Sphinx-"
-             version ".tar.gz"))
+       (uri (pypi-uri "Sphinx" version))
        (sha256
         (base32
-         "011xizm3jnmf4cvs5i6kgf6c5nn046h79i8j0vd0f27yw9j3p4wl"))))
+         "185zklh44fhrwp1dg6251g3w6zmssh5jzvbz8pvmkg9l6wvxdzry"))))
     (build-system python-build-system)
     (inputs
-     `(("python-setuptools" ,python-setuptools)
-       ("python-jinja2" ,python-jinja2)
+     `(
+       ("python-alabaster" ,python-alabaster)
+       ("python-babel" ,python-babel)
        ("python-docutils" ,python-docutils)
-       ("python-pygments" ,python-pygments)))
+       ("python-imagesize" ,python-imagesize)
+       ("python-jinja2" ,python-jinja2)
+       ("python-pygments" ,python-pygments)
+       ("python-pytz" ,python-pytz)
+       ("python-setuptools" ,python-setuptools)
+       ("python-six" ,python-six)))
+
+    ;; Several packages that use Sphinx want to use these propagated
+    ;; dependencies when using Sphinx.  Rather than add them to all the Sphinx
+    ;; users, we propagate them from Sphinx.
+    (propagated-inputs
+     `(("python-pytz" ,python-pytz)
+       ("python-snowballstemmer" ,python-snowballstemmer)))
     (home-page "http://sphinx-doc.org/")
     (synopsis "Python documentation generator")
     (description "Sphinx is a tool that makes it easy to create documentation