summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-08-14 14:44:23 +0200
committerRicardo Wurmus <rekado@elephly.net>2020-08-14 14:50:59 +0200
commita86f51dccaa7292630e4a2d91330f3e7f67ecac5 (patch)
treed6fdfadc22d651e355fb096cbaa766f8f8eabda3
parent222040095727d1ebb23a7f3755c7908c52eff381 (diff)
downloadguix-a86f51dccaa7292630e4a2d91330f3e7f67ecac5.tar.gz
gnu: Add r-rfast.
* gnu/packages/cran.scm (r-rfast): New variable.
-rw-r--r--gnu/packages/cran.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5b94d7572e..50428f23a5 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -22954,3 +22954,29 @@ times starting with Leong et al (2005,
 aggregation for comparing different implementations in order to provide a
 'faster but good enough' alternative for use with R and C++ code.")
     (license license:gpl2+)))
+
+(define-public r-rfast
+  (package
+    (name "r-rfast")
+    (version "1.9.9")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "Rfast" version))
+       (sha256
+        (base32
+         "18m8xhg24kygwhq7avdp1hibilicb5wppi2wdmc36fkqljc274y0"))))
+    (properties `((upstream-name . "Rfast")))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-rcpp" ,r-rcpp)
+       ("r-rcpparmadillo" ,r-rcpparmadillo)
+       ("r-rcppziggurat" ,r-rcppziggurat)))
+    (home-page "https://github.com/RfastOfficial/Rfast")
+    (synopsis "Collection of efficient and fast R functions")
+    (description
+     "This package provides a collection of fast (utility) functions for data
+analysis.  Column- and row- wise means, medians, variances, minimums,
+maximums, many t, F and G-square tests, many regressions (normal, logistic,
+Poisson), are some of the many fast functions.")
+    (license license:gpl2+)))