summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2015-12-10 05:30:09 +0200
committerEfraim Flashner <efraim@flashner.co.il>2015-12-10 16:09:16 +0200
commitb01bbbcf3d28db885a48f74908214b12e18e7861 (patch)
tree63eb82b3396c024caed4abe72b36f87077404294
parent16414017f30f944cfe964f1d9141bdcbf56be857 (diff)
downloadguix-b01bbbcf3d28db885a48f74908214b12e18e7861.tar.gz
gnu: python-pytz: Update to 2015.7.
* gnu/packages/python.scm (python-pytz): Update to 2015.7.
[source]: Change uri to pypi's location.
[home-page]: Change to new website.
[license]: Change to expat.
-rw-r--r--gnu/packages/python.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 9fe945ee90..afc9dcd6a2 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -574,23 +574,22 @@ Cassandra cluster on localhost.")
 (define-public python-pytz
   (package
     (name "python-pytz")
-    (version "2013b")
+    (version "2015.7")
     (source
      (origin
       (method url-fetch)
-      (uri (string-append "https://launchpad.net/pytz/main/" version
-                          "/+download/pytz-" version ".tar.bz2"))
+      (uri (pypi-uri "pytz" version))
       (sha256
        (base32
-        "19giwgfcrg0nr1gdv49qnmf2jb2ilkcfc7qyqvfpz4dp0p64ksv5"))))
+        "1spgdfp1ssya7v3kww7zp71xpj437skpqazcvqr3kr1p1brnw9lr"))))
     (build-system python-build-system)
     (arguments `(#:tests? #f)) ; no test target
-    (home-page "https://launchpad.net/pytz")
+    (home-page "http://pythonhosted.org/pytz")
     (synopsis "Python timezone library")
     (description
      "This library allows accurate and cross platform timezone calculations
 using Python 2.4 or higher and provides access to the Olson timezone database.")
-    (license x11)))
+    (license license:expat)))
 
 (define-public python2-pytz
   (package-with-python2 python-pytz))