summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-17 11:28:13 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-17 14:50:13 +0200
commitba95233f84189ec0a51cde6aedd704a8f058d3e2 (patch)
tree26930d58c3de62c25a8a75303ee7652c42e90a04
parent0cfdc7506be2d879d2b76050a4f4188422682831 (diff)
downloadguix-ba95233f84189ec0a51cde6aedd704a8f058d3e2.tar.gz
gnu: ucx: Disable optimizations specific to the build machine.
* gnu/packages/fabric-management.scm (ucx)[arguments]: Replace
"--enable-optimizations" with "--disable-optimizations".
-rw-r--r--gnu/packages/fabric-management.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/fabric-management.scm b/gnu/packages/fabric-management.scm
index 9b30b09df5..e822a3fb20 100644
--- a/gnu/packages/fabric-management.scm
+++ b/gnu/packages/fabric-management.scm
@@ -193,16 +193,21 @@ testing InfiniBand networks.")
                 "0x3clvy716i7va4m4adgx6ihjsfnzrkdizhxz5v52944dkglpc8n"))))
     (build-system gnu-build-system)
     (arguments
-     '( ;; These are the flags found in 'contrib/configure-release'.
-       #:configure-flags (list "--enable-optimizations"
-                               "--disable-logging"
-                               "--disable-debug"
-                               "--disable-assertions"
-                               "--disable-params-check"
+     '( ;; These are some of the flags found in 'contrib/configure-release'.
+       #:configure-flags (list
+                          ;; XXX: Disable optimizations specific to the build
+                          ;; machine (AVX, etc.)  There's apparently no way to
+                          ;; have them picked up at load time.
+                          "--disable-optimizations"
 
-                               (string-append "--with-rdmacm="
-                                              (assoc-ref %build-inputs
-                                                         "rdma-core")))))
+                          "--disable-logging"
+                          "--disable-debug"
+                          "--disable-assertions"
+                          "--disable-params-check"
+
+                          (string-append "--with-rdmacm="
+                                         (assoc-ref %build-inputs
+                                                    "rdma-core")))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)