summary refs log tree commit diff
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2020-03-28 11:34:54 -0400
committerLeo Famulari <leo@famulari.name>2020-03-28 11:50:41 -0400
commite4257138fe1d924c56c9979b75319585b9251fb7 (patch)
treeaf4d62e85b543eb5fd142f4ab01a232d74d8ce0d
parent388b432cea4ae2bb9bf4b044026b7764ab002e1e (diff)
downloadguix-e4257138fe1d924c56c9979b75319585b9251fb7.tar.gz
Revert "gnu: gnupg: Use ~/.guix-profile/bin/pinentry by default."
This commit didn't work:

https://issues.guix.gnu.org/issue/24076#13

This reverts commit c7af9d0b5ebaa1fdb08ff5d8a56004998bcd8103.
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/gnupg.scm5
-rw-r--r--gnu/packages/patches/gnupg-default-pinentry.patch15
3 files changed, 2 insertions, 19 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 60d6d912f5..52c65f0c31 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -973,7 +973,6 @@ dist_patch_DATA =						\
   %D%/packages/patches/gmp-faulty-test.patch			\
   %D%/packages/patches/gnome-shell-theme.patch			\
   %D%/packages/patches/gnome-tweaks-search-paths.patch		\
-  %D%/packages/patches/gnupg-default-pinentry.patch		\
   %D%/packages/patches/gnutls-skip-trust-store-test.patch	\
   %D%/packages/patches/gobject-introspection-absolute-shlib-path.patch \
   %D%/packages/patches/gobject-introspection-cc.patch		\
diff --git a/gnu/packages/gnupg.scm b/gnu/packages/gnupg.scm
index fc5b4fbc63..856c01a6d8 100644
--- a/gnu/packages/gnupg.scm
+++ b/gnu/packages/gnupg.scm
@@ -1,5 +1,5 @@
 ;;; GNU Guix --- Functional package management for GNU
-;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019, 2020 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2012, 2013, 2014, 2015, 2016, 2017, 2018, 2019 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2013, 2015, 2018 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2014, 2018 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2014, 2015, 2016 Mark H Weaver <mhw@netris.org>
@@ -254,8 +254,7 @@ compatible to GNU Pth.")
                                   ".tar.bz2"))
               (sha256
                (base32
-                "0c6a4v9p6qzhsw1pfcwc459bxpc8hma0w9z8iqb9khvligack9q4"))
-              (patches (search-patches "gnupg-default-pinentry.patch"))))
+                "0c6a4v9p6qzhsw1pfcwc459bxpc8hma0w9z8iqb9khvligack9q4"))))
     (build-system gnu-build-system)
     (native-inputs
      `(("pkg-config" ,pkg-config)))
diff --git a/gnu/packages/patches/gnupg-default-pinentry.patch b/gnu/packages/patches/gnupg-default-pinentry.patch
deleted file mode 100644
index 272f4b53dc..0000000000
--- a/gnu/packages/patches/gnupg-default-pinentry.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-Default to the pinentry program installed in ~/.guix-profile.
-
-diff --git a/common/homedir.c b/common/homedir.c
-index e9e75d0..74e0aaf 100644
---- a/common/homedir.c
-+++ b/common/homedir.c
-@@ -968,7 +968,7 @@ get_default_pinentry_name (int reset)
-   } names[] = {
-     /* The first entry is what we return in case we found no
-        other pinentry.  */
--    { gnupg_bindir, DIRSEP_S "pinentry" EXEEXT_S },
-+    { gnupg_homedir, "/.guix-profile/bin/pinentry" },
- #ifdef HAVE_W32_SYSTEM
-     /* Try Gpg4win directory (with bin and without.) */
-     { w32_rootdir, "\\..\\Gpg4win\\bin\\pinentry.exe" },