summary refs log tree commit diff
diff options
context:
space:
mode:
authorJan (janneke) Nieuwenhuizen <janneke@gnu.org>2021-12-15 11:34:45 +0100
committerJan (janneke) Nieuwenhuizen <janneke@gnu.org>2022-10-18 22:59:58 +0200
commited906c84c72e4adc14cfbeea734171e177510877 (patch)
tree925393d6f0e58ac92b99307c973f14d20de613b4
parent4984e737b7b739ece7c9bbac3053cd2ad3c50ece (diff)
downloadguix-ed906c84c72e4adc14cfbeea734171e177510877.tar.gz
DRAFT gnu: bootstrap: %bootstrap-mes: Support ARM.
XXX TODO:
  * rebase onto core-updates
  * release mes-0.23
  * rebuild

Built with
    7f847ea20b90c2fb8dc3b5eb51e6c007a8c5461a
    DRAFT bootstrap: mes-minimal: Support ARM, update to mes-0.22.115.

* gnu/packages/bootstrap.scm (%bootstrap-mes)[inputs]: Add tarball for
armhf-linux.
[supported-systems]: Add armhf-linux, aarch64-linux.
-rw-r--r--gnu/packages/bootstrap.scm18
1 files changed, 13 insertions, 5 deletions
diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index b84fd765d6..6f5b21b8f0 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -1025,14 +1025,22 @@ exec ~a/bin/.gcc-wrapped -B~a/lib \
           (origin
             (method url-fetch)
             (uri (map
-                  (cute string-append <>
-                        "/i686-linux/20190815/"
-                        "mes-minimal-stripped-0.19-i686-linux.tar.xz")
+                  (cute string-append <> (%current-system) "/"
+                       (match (%current-system)
+                         ((or "armhf-linux" "aarch64-linux")
+                          "20201217/mes-minimal-stripped-0.22-115-gdacaed9fe-armhf-linux.tar.xz")
+                         ((or "i686-linux" "x86_64-linux")
+                          "20190815/mes-minimal-stripped-0.19-i686-linux.tar.xz")))
                   %bootstrap-base-urls))
             (sha256
              (base32
-              "1q4xjpx6nbn44kxnilpgl12bhpmwy2bblzwszc2ci7xkf400jcpv")))))))
-    (supported-systems '("i686-linux" "x86_64-linux"))
+              (match (%current-system)
+                ((or "armhf-linux" "aarch64-linux")
+                 "0daz658r9psmqxjkayvr8ymql6h4gf11gwdd4k3mdv7czc5ak399")
+                ((or "i686-linux" "x86_64-linux")
+                 "1q4xjpx6nbn44kxnilpgl12bhpmwy2bblzwszc2ci7xkf400jcpv")))))))))
+    (supported-systems '("armhf-linux" "aarch64-linux"
+                         "i686-linux" "x86_64-linux"))
     (synopsis "Bootstrap binaries of Mes")
     (description synopsis)
     (home-page #f)