summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-01-09 14:46:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-09 15:43:50 +0100
commit2871b670a8075e876873296dfa7ac11628926fc9 (patch)
tree403b2dbdf38f339159142406c87066c84b1eef38
parentd0eb09a13455ba767c54eaf577268326ebd6c61a (diff)
downloadguix-2871b670a8075e876873296dfa7ac11628926fc9.tar.gz
gnu: Add r-kohonen.
* gnu/packages/cran.scm (r-kohonen): New variable.
-rw-r--r--gnu/packages/cran.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 54b0f4626e..f768bcc5ba 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -9189,3 +9189,27 @@ handling.")
      "This package provides functions for converting, importing, and drawing
 PostScript pictures in R plots.")
     (license license:gpl2+)))
+
+(define-public r-kohonen
+  (package
+    (name "r-kohonen")
+    (version "3.0.8")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (cran-uri "kohonen" version))
+       (sha256
+        (base32
+         "1zbfqa1qdlry8w6xhypkiknc5gn98v1ijhlsfka8zjg8ajhqgn1q"))))
+    (build-system r-build-system)
+    (propagated-inputs
+     `(("r-mass" ,r-mass)
+       ("r-rcpp" ,r-rcpp)))
+    (home-page "https://cran.r-project.org/web/packages/kohonen")
+    (synopsis "Supervised and unsupervised self-organising maps")
+    (description
+     "This package provides functions to train @dfn{self-organising
+maps} (SOMs).  Also interrogation of the maps and prediction using trained
+maps are supported.  The name of the package refers to Teuvo Kohonen, the
+inventor of the SOM.")
+    (license license:gpl2+)))