summary refs log tree commit diff
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2019-09-03 03:08:34 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2019-09-03 03:08:34 +0200
commit5bdd10bdfcff13c627ff49fb594b83d2c3bd304f (patch)
treedb9fbed4e36796207c6f9b409c4480f570d2d07f
parent7b06a3d0caa6f83554d6c787ea7a63a086dd60fc (diff)
downloadguix-5bdd10bdfcff13c627ff49fb594b83d2c3bd304f.tar.gz
gnu: buildroot-boards: Install support scripts.
* gnu/packages/buildroot.scm (buildroot-boards)[arguments]<#:phases>[install]:
Install support scripts.
-rw-r--r--gnu/packages/buildroot.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/buildroot.scm b/gnu/packages/buildroot.scm
index 84c1381fb3..710aba5079 100644
--- a/gnu/packages/buildroot.scm
+++ b/gnu/packages/buildroot.scm
@@ -58,9 +58,10 @@
          (delete 'check)
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
-             (let ((destination (string-append (assoc-ref outputs "out")
-                                               "/share/buildroot/board")))
-               (copy-recursively "board" destination))
+             (let ((out-share (string-append (assoc-ref outputs "out")
+                                             "/share/buildroot/")))
+               (copy-recursively "board" (string-append out-share "board"))
+               (copy-recursively "support" (string-append out-share "support")))
              #t)))))
     (synopsis "Generate embedded Linux system images")
     (description "@code{buildroot} generates embedded Linux system images.")