summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-06 08:44:21 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-06 10:30:18 +0200
commit937bc2d1370b8581d37c49b5281a7b8ebdfe8312 (patch)
tree473cbc8da54168c0d9f85a1aea59541c51625b6e
parent7f4658983a742072be4e28b227d6349461e9a68b (diff)
downloadguix-937bc2d1370b8581d37c49b5281a7b8ebdfe8312.tar.gz
gnu: bullet: Update to 2.85.1.
* gnu/packages/game-development.scm (bullet): Update to 2.85.1.
[source]: Change to new Github url.
[arguments]: Enable tests, build shared libraries.
[inputs]: Add glu, libx11, mesa.
-rw-r--r--gnu/packages/game-development.scm23
1 files changed, 14 insertions, 9 deletions
diff --git a/gnu/packages/game-development.scm b/gnu/packages/game-development.scm
index 693d728464..76c06ecc72 100644
--- a/gnu/packages/game-development.scm
+++ b/gnu/packages/game-development.scm
@@ -69,20 +69,25 @@
 (define-public bullet
   (package
     (name "bullet")
-    (version "2.82-r2704")
+    (version "2.85.1")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://bullet.googlecode.com/files/bullet-"
-                                  version ".tgz"))
+              (uri (string-append "https://github.com/bulletphysics/bullet3/"
+                                  "archive/" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1lnfksxa9b1slyfcxys313ymsllvbsnxh9np06azkbgpfvmwkr37"))))
+                "0qpd37ws0xlxwy55dg058a5b4yw2jxiz09yyc3lc0frpa05pq5bf"))))
     (build-system cmake-build-system)
-    (arguments '(#:tests? #f ; no 'test' target
-                 #:configure-flags (list
-                                    (string-append
-                                     "-DCMAKE_CXX_FLAGS=-fPIC "
-                                     (or (getenv "CXXFLAGS") "")))))
+    (arguments
+     '(#:configure-flags (list (string-append
+                                 "-DBUILD_SHARED_LIBS=ON "
+                                 "-DCMAKE_CXX_FLAGS=-fPIC "
+                                 (or (getenv "CXXFLAGS") "")))))
+    (inputs
+     `(("glu" ,glu)
+       ("libx11" ,libx11)
+       ("mesa" ,mesa)))
     (home-page "http://bulletphysics.org/")
     (synopsis "3D physics engine library")
     (description