summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-08-31 15:34:58 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-09-03 14:31:51 +0200
commita45ba1270c382657c76ead6223a7ec1a3ce607c7 (patch)
tree0f83e82932833a5a8986ca7ddaa53b147572c481
parent9a4d8968f0328e3cfb6265325bf096d745a5b51e (diff)
downloadguix-a45ba1270c382657c76ead6223a7ec1a3ce607c7.tar.gz
gnu: Add r-rcolorbrewer.
* gnu/packages/statistics.scm (r-rcolorbrewer): New variable.
-rw-r--r--gnu/packages/statistics.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index c4a82d38ea..e3ab548406 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -332,3 +332,23 @@ panels or collapse high-dimensional arrays to simpler summary statistics.")
      "Proto is an object oriented system using object-based, also called
 prototype-based, rather than class-based object oriented ideas.")
     (license license:gpl2+)))
+
+(define-public r-rcolorbrewer
+  (package
+    (name "r-rcolorbrewer")
+    (version "1.1-2")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "mirror://cran/src/contrib/RColorBrewer_"
+                           version ".tar.gz"))
+       (sha256
+        (base32 "1pfcl8z1pnsssfaaz9dvdckyfnnc6rcq56dhislbf571hhg7isgk"))))
+    (build-system r-build-system)
+    (home-page "http://cran.r-project.org/web/packages/RColorBrewer")
+    (synopsis "ColorBrewer palettes")
+    (description
+     "This package provides color schemes for maps (and other graphics)
+designed by Cynthia Brewer as described at http://colorbrewer2.org")
+    ;; Includes code licensed under bsd-4
+    (license license:asl2.0)))