summary refs log tree commit diff
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2016-11-01 13:20:46 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-11-04 21:23:08 +0100
commitc27ae827da71dffcbc42f813a9b59c4114d7869b (patch)
tree53e1800e84cb096c15c1978b465c74c6821c90e3
parentaccd5f996e2cfda656dee3cba97de5fd3cec3ad9 (diff)
downloadguix-c27ae827da71dffcbc42f813a9b59c4114d7869b.tar.gz
gnu: Add jupyter.
* gnu/packages/python.scm (jupyter): New variable.
-rw-r--r--gnu/packages/python.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index a1148b1c38..518ab3a50c 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -6934,6 +6934,36 @@ Jupyter kernels such as IJulia and IRKernel.")
 (define-public python2-jupyter-console
   (package-with-python2 python-jupyter-console))
 
+(define-public jupyter
+  (package
+    (name "jupyter")
+    (version "1.0.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (pypi-uri "jupyter" version))
+       (sha256
+        (base32
+         "0pwf3pminkzyzgx5kcplvvbvwrrzd3baa7lmh96f647k30rlpp6r"))))
+    (build-system python-build-system)
+    ;; FIXME: it's not clear how to run the tests.
+    (arguments `(#:tests? #f))
+    (propagated-inputs
+     `(("python-ipykernel" ,python-ipykernel)
+       ("python-ipywidgets" ,python-ipywidgets)
+       ("python-jupyter-console" ,python-jupyter-console)
+       ("python-nbconvert" ,python-nbconvert)
+       ("python-notebook" ,python-notebook)
+       ("python-setuptools" ,python-setuptools)))
+    (home-page "http://jupyter.org")
+    (synopsis "Web application for interactive documents")
+    (description
+     "The Jupyter Notebook is a web application that allows you to create and
+share documents that contain live code, equations, visualizations and
+explanatory text.  Uses include: data cleaning and transformation, numerical
+simulation, statistical modeling, machine learning and much more.")
+    (license license:bsd-3)))
+
 (define-public python-chardet
   (package
     (name "python-chardet")