summary refs log tree commit diff
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-09-02 15:51:26 +0300
committerEfraim Flashner <efraim@flashner.co.il>2019-09-02 15:54:59 +0300
commiteb98d5a83ce98ece279fec51085521aafd976ec4 (patch)
tree0bf6410b7fa8b273ab57bdaf5d0e11542240611d
parent74394983665a13573285f79060bcbb699fc2cecd (diff)
downloadguix-eb98d5a83ce98ece279fec51085521aafd976ec4.tar.gz
gnu: Add rust-heapsize-plugin, rust-language-tags.
* gnu/packages/crates-io.scm (rust-heapsize-plugin, rust-language-tags):
New variables.
-rw-r--r--gnu/packages/crates-io.scm59
1 files changed, 59 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 9aa995ef94..6f2a002a2f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -681,6 +681,37 @@ heap.")
      `(#:cargo-inputs (("rust-kernel32-sys" ,rust-kernel32-sys))
        #:tests? #f)))) ;; No flexible-tests feature flags on this release.
 
+;; This package makes use of removed features
+(define-public rust-heapsize-plugin
+  (package
+    (name "rust-heapsize-plugin")
+    (version "0.1.6")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "heapsize_plugin" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "1i72isf699q9jl167g2kg4xd6h3cd05rc79zaph58aqjy0g0m9y9"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-development-inputs (("rust-heapsize" ,rust-heapsize-0.3))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'fix-Cargo-toml
+           (lambda _
+             (substitute* "Cargo.toml"
+               (("path = \"..\", ") ""))
+             #t)))))
+    (home-page "https://github.com/servo/heapsize")
+    (synopsis "Measure runtime size of an object on the heap")
+    (description
+     "This package automatically generates infrastructure for measuring the
+total runtime size of an object on the heap")
+    (properties `((hidden? . #t)))
+    (license license:mpl2.0)))
+
 (define-public rust-hex
   (package
     (name "rust-hex")
@@ -818,6 +849,34 @@ friction with idiomatic Rust structs to ease interopability.")
 kernel32.")
     (license license:expat)))
 
+(define-public rust-language-tags
+  (package
+    (name "rust-language-tags")
+    (version "0.2.2")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (crate-uri "language-tags" version))
+        (file-name (string-append name "-" version ".tar.gz"))
+        (sha256
+         (base32
+          "16hrjdpa827carq5x4b8zhas24d8kg4s16m6nmmn1kb7cr5qh7d9"))))
+    (build-system cargo-build-system)
+    (arguments
+     `(#:cargo-inputs
+       (("rust-heapsize" ,rust-heapsize-0.3))
+       #:cargo-development-inputs
+       (("rust-heapsize-plugin" ,rust-heapsize-plugin))))
+    (home-page "https://github.com/pyfisch/rust-language-tags")
+    (synopsis "Language tags for Rust")
+    (description
+     "Language tags can be used identify human languages, scripts e.g. Latin
+script, countries and other regions.  They are commonly used in HTML and HTTP
+@code{Content-Language} and @code{Accept-Language} header fields.  This package
+currently supports parsing (fully conformant parser), formatting and comparing
+language tags.")
+    (license license:expat)))
+
 (define-public rust-lazy-static
   (package
     (name "rust-lazy-static")