summary refs log tree commit diff
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2016-10-31 13:15:38 +0000
committerMarius Bakke <mbakke@fastmail.com>2016-11-06 16:17:29 +0000
commitf4dc22bcd95eaebb026457c0a36396517be64130 (patch)
tree32c7f124f4204f09ea14046346d4df1417669a8b
parent331ef882ff370d0f2e4f393d280b64594dd956a9 (diff)
downloadguix-f4dc22bcd95eaebb026457c0a36396517be64130.tar.gz
gnu: nmap: Update to 7.31.
* gnu/packages/admin.scm (nmap): Update to 7.31.
[arguments]: Add phase 'patch-Makefile' to prevent lua from being built.
-rw-r--r--gnu/packages/admin.scm10
1 files changed, 8 insertions, 2 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 1d577c73bc..77432c4d9b 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1570,14 +1570,14 @@ done with the @code{auditctl} utility.")
 (define-public nmap
   (package
     (name "nmap")
-    (version "7.12")
+    (version "7.31")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://nmap.org/dist/nmap-" version
                                   ".tar.bz2"))
               (sha256
                (base32
-                "014vagh9ak10hidwzp9s6g30y5h5fhsh8wykcnc1hnn9hwm0ipv3"))
+                "0hiqb28950kn4bjsmw0ksfyss7j2qdmgrj3xsjf7073pq01lx7yb"))
               (modules '((guix build utils)))
               (snippet
                '(map delete-file-recursively
@@ -1603,6 +1603,12 @@ done with the @code{auditctl} utility.")
      '(#:configure-flags '("--without-zenmap")
        #:phases
        (modify-phases %standard-phases
+         (add-after 'configure 'patch-Makefile
+           (lambda _
+             (substitute* "Makefile"
+               ;; Do not attempt to build lua.
+               (("build-dnet build-lua") "build-dnet"))
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (define (make out . args)