summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-16 11:14:01 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit25eb1c2227daadf85b6c20e204c2109ca70becba (patch)
treefc2cf52d7fc0ce5dd5cba2249a111122515900d3
parente0d17b848226ef9401b1d588896942a96b1fdbd4 (diff)
downloadguix-25eb1c2227daadf85b6c20e204c2109ca70becba.tar.gz
gnu: Add ghc-xhtml.
* gnu/packages/haskell.scm (ghc-xhtml): New variable.
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index b8875ae0b1..55f3de0e56 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -541,6 +541,28 @@ them.")
 documents.")
     (license bsd-3)))
 
+(define-public ghc-xhtml
+  (package
+    (name "ghc-xhtml")
+    (version "3000.2.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/xhtml/xhtml-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "1n6wgzxbj8xf0wf1il827qidphnffb5vzhwzqlxhh70c2y10f0ik"))))
+    (build-system haskell-build-system)
+    (home-page "https://github.com/haskell/xhtml")
+    (synopsis "XHTML combinator library")
+    (description
+     "This package provides combinators for producing XHTML 1.0, including the
+Strict, Transitional and Frameset variants.")
+    (license bsd-3)))
+
 (define-public ghc-haskell-src
   (package
     (name "ghc-haskell-src")