summary refs log tree commit diff
diff options
context:
space:
mode:
authorPaul van der Walt <paul@denknerd.org>2015-10-15 14:14:34 +0200
committerPaul van der Walt <paul@denknerd.org>2015-10-23 09:10:52 +0200
commit801cc88daf1ac810c95db2e5992c939bbc115d78 (patch)
tree4e881e1ca5d9c810939dba00ef75e1fc897b7a65
parent5ef40cb26a70a48680ce32875d7f0c4f2a95c746 (diff)
downloadguix-801cc88daf1ac810c95db2e5992c939bbc115d78.tar.gz
gnu: Add ghc-unix-compat.
* gnu/packages/haskell.scm (ghc-unix-compat): New variable.
-rw-r--r--gnu/packages/haskell.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ebaf1f75e0..40d869dfc1 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1000,6 +1000,30 @@ but also need those types.")
 for Unix time in Haskell.")
     (license bsd-3)))
 
+(define-public ghc-unix-compat
+  (package
+    (name "ghc-unix-compat")
+    (version "0.4.1.4")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/unix-compat/unix-compat-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "0jxk7j5pz2kgfpqr4hznndjg31pqj5xg2qfc5308fcn9xyg1myps"))))
+    (build-system haskell-build-system)
+    (home-page
+     "http://github.com/jystic/unix-compat")
+    (synopsis "Portable POSIX-compatibility layer")
+    (description
+     "This package provides portable implementations of parts of the unix
+package.  This package re-exports the unix package when available.  When it
+isn't available, portable implementations are used.")
+    (license bsd-3)))
+
 (define-public ghc-iproute
   (package
     (name "ghc-iproute")