summary refs log tree commit diff
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-07-27 04:03:28 -0400
committerMark H Weaver <mhw@netris.org>2015-08-18 23:52:57 -0400
commit86e3f95a09d903debba38cd1ff5dfd953f34a765 (patch)
tree1ccc088ad87b1d2121746b7e68fdcd40f1918d67
parente640340b9ec6c601720977820b2701d6cd99b74c (diff)
downloadguix-86e3f95a09d903debba38cd1ff5dfd953f34a765.tar.gz
PRELIMINARY: Add dbus-fixed.
-rw-r--r--gnu/packages/glib.scm18
1 files changed, 18 insertions, 0 deletions
diff --git a/gnu/packages/glib.scm b/gnu/packages/glib.scm
index 88c61b676b..9db54b7863 100644
--- a/gnu/packages/glib.scm
+++ b/gnu/packages/glib.scm
@@ -116,6 +116,24 @@ or through unencrypted TCP/IP suitable for use behind a firewall with
 shared NFS home directories.")
     (license license:gpl2+)))                     ; or Academic Free License 2.1
 
+;; XXX This fixed version is needed only for 'dbus-daemon-launch-helper'.
+;; FIXME: Integrate this change into the main 'dbus' package in the next
+;; core-updates cycle.
+(define dbus-fixed
+  (package
+    (inherit dbus)
+    (arguments
+     (substitute-keyword-arguments (package-arguments dbus)
+       ((#:phases phases)
+        `(modify-phases ,phases
+           (add-after
+            'unpack 'add-standard-system-service-dir
+            (lambda _
+              (substitute* "dbus/dbus-sysdeps-util-unix.c"
+                (("standard_search_path\\[\\] =" all)
+                 (format #f "~a ~s" all "/run/current-system/profile/share:")))
+              #t))))))))
+
 (define glib
   (package
    (name "glib")