summary refs log tree commit diff
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2012-09-01 11:52:52 +0200
committerLudovic Courtès <ludo@gnu.org>2012-09-01 11:52:52 +0200
commit9dd036f35c9a825c30aecc9eb3a3f6266481cfe3 (patch)
treeaf3bc96172584ac7aeef863ad9b4c04bf04af887
parent6dd7787c391884f978a11a6673fb934fdb0e6ef1 (diff)
downloadguix-9dd036f35c9a825c30aecc9eb3a3f6266481cfe3.tar.gz
distro: m4: Add patch to allow builds with glibc 2.16+.
* distro/base.scm (m4): Use `m4-gets-undeclared.patch'.

* distro/patches/m4-gets-undeclared.patch: New file.
* Makefile.am (dist_patch_DATA): Add it.
-rw-r--r--Makefile.am1
-rw-r--r--distro/base.scm9
-rw-r--r--distro/patches/m4-gets-undeclared.patch45
3 files changed, 52 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index fb22bef2a7..bdcb90a701 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -41,6 +41,7 @@ patchdir = $(pkgdatadir)/patches
 dist_patch_DATA =				\
   distro/patches/binutils-ld-new-dtags.patch	\
   distro/patches/guile-1.8-cpp-4.5.patch	\
+  distro/patches/m4-gets-undeclared.patch	\
   distro/patches/m4-readlink-EINVAL.patch	\
   distro/patches/m4-s_isdir.patch		\
   distro/patches/make-impure-dirs.patch		\
diff --git a/distro/base.scm b/distro/base.scm
index 949cb571b1..c3a6846581 100644
--- a/distro/base.scm
+++ b/distro/base.scm
@@ -389,14 +389,17 @@ are expected to exist on every operating system.")
                                             "i686-sunos")))
                    #:patches (list (assoc-ref %build-inputs "patch/s_isdir")
                                    (assoc-ref %build-inputs
-                                              "patch/readlink-EINVAL"))))
+                                              "patch/readlink-EINVAL")
+                                   (assoc-ref %build-inputs "patch/gets"))))
                 ((system cross-system)
                  `(#:patches (list (assoc-ref %build-inputs "patch/s_isdir")
                                    (assoc-ref %build-inputs
-                                              "patch/readlink-EINVAL"))))))
+                                              "patch/readlink-EINVAL")
+                                   (assoc-ref %build-inputs "patch/gets"))))))
    (inputs `(("patch/s_isdir" ,(search-patch "m4-s_isdir.patch"))
              ("patch/readlink-EINVAL"
-              ,(search-patch "m4-readlink-EINVAL.patch"))))
+              ,(search-patch "m4-readlink-EINVAL.patch"))
+             ("patch/gets" ,(search-patch "m4-gets-undeclared.patch"))))
    (description "GNU M4, a macro processor")
    (long-description
     "GNU M4 is an implementation of the traditional Unix macro processor.  It
diff --git a/distro/patches/m4-gets-undeclared.patch b/distro/patches/m4-gets-undeclared.patch
new file mode 100644
index 0000000000..d28f0cdcc4
--- /dev/null
+++ b/distro/patches/m4-gets-undeclared.patch
@@ -0,0 +1,45 @@
+This patch is needed to allow builds with newer versions of
+the GNU libc (2.16+).
+
+The upstream fix was:
+
+  commit 66712c23388e93e5c518ebc8515140fa0c807348
+  Author: Eric Blake <eblake@redhat.com>
+  Date:   Thu Mar 29 13:30:41 2012 -0600
+
+      stdio: don't assume gets any more
+
+      Gnulib intentionally does not have a gets module, and now that C11
+      and glibc have dropped it, we should be more proactive about warning
+      any user on a platform that still has a declaration of this dangerous
+      interface.
+
+      * m4/stdio_h.m4 (gl_STDIO_H, gl_STDIO_H_DEFAULTS): Drop gets
+      support.
+      * modules/stdio (Makefile.am): Likewise.
+      * lib/stdio-read.c (gets): Likewise.
+      * tests/test-stdio-c++.cc: Likewise.
+      * m4/warn-on-use.m4 (gl_WARN_ON_USE_PREPARE): Fix comment.
+      * lib/stdio.in.h (gets): Make warning occur in more places.
+      * doc/posix-functions/gets.texi (gets): Update documentation.
+      Reported by Christer Solskogen.
+
+      Signed-off-by: Eric Blake <eblake@redhat.com>
+
+This patch just gets rid of the offending part.
+
+--- m4-1.4.16/lib/stdio.in.h.orig	2012-09-01 01:05:36.000000000 +0200
++++ m4-1.4.16/lib/stdio.in.h	2012-09-01 01:05:42.000000000 +0200
+@@ -158,12 +158,6 @@ _GL_WARN_ON_USE (fflush, "fflush is not
+                  "use gnulib module fflush for portable POSIX compliance");
+ #endif
+ 
+-/* It is very rare that the developer ever has full control of stdin,
+-   so any use of gets warrants an unconditional warning.  Assume it is
+-   always declared, since it is required by C89.  */
+-#undef gets
+-_GL_WARN_ON_USE (gets, "gets is a security hole - use fgets instead");
+-
+ #if @GNULIB_FOPEN@
+ # if @REPLACE_FOPEN@
+ #  if !(defined __cplusplus && defined GNULIB_NAMESPACE)