summary refs log tree commit diff
diff options
context:
space:
mode:
authorFederico Beffa <beffa@fbengineering.ch>2015-03-27 18:58:03 +0100
committerFederico Beffa <beffa@fbengineering.ch>2015-04-08 17:31:13 +0200
commitabfed253e69c2ef2a7a1b728eee28b482e889c21 (patch)
tree3b92b059dfc2b2324dbf0aada2cd29c02074a3e0
parentf50fc13815d327c554fecf6f9bc96c1a6f2f4211 (diff)
downloadguix-abfed253e69c2ef2a7a1b728eee28b482e889c21.tar.gz
gnu: Add ghc-network.
* gnu/packages/haskell.scm (ghc-network): New variable.
-rw-r--r--gnu/packages/haskell.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index ee150130ab..0bf927f691 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -777,4 +777,34 @@ is also parametric in the input stream type.")
 mutable and immutable), with a powerful loop optimisation framework.")
   (license bsd-3)))
 
+(define-public ghc-network
+  (package
+    (name "ghc-network")
+    (version "2.6.0.2")
+    (outputs '("out" "doc"))
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "http://hackage.haskell.org/package/network/network-"
+             version
+             ".tar.gz"))
+       (sha256
+        (base32
+         "12b7saam5ga6l4cplgkad49xa4vkynz2ri9jxidx1cxiqjcl0vc4"))))
+    (build-system haskell-build-system)
+    (inputs
+     `(("ghc-hunit" ,ghc-hunit)))
+    (arguments
+     `(#:tests? #f  ; FIXME: currently missing libraries used for tests.
+       #:phases
+       (modify-phases %standard-phases
+         (add-before configure set-sh
+                     (lambda _ (setenv "CONFIG_SHELL" "sh"))))))
+    (home-page "https://github.com/haskell/network")
+    (synopsis "Low-level networking interface")
+    (description
+     "This package provides a low-level networking interface.")
+    (license bsd-3)))
+
 ;;; haskell.scm ends here