summary refs log tree commit diff
diff options
context:
space:
mode:
authorTimothy Sample <samplet@ngyro.com>2021-11-18 00:17:52 -0500
committerTimothy Sample <samplet@ngyro.com>2021-11-18 10:10:17 -0500
commit17ebc4eebeab0e4bef8094c40b0d853ba221edcd (patch)
treeeb657d24084550fcc88dbf8dd8a79d5fac7d618c
parent40372653d9f6ea16c7f4428010ec7a5657b5f0b7 (diff)
downloadguix-17ebc4eebeab0e4bef8094c40b0d853ba221edcd.tar.gz
gnu: gnome-control-center: Fix build.
See <https://github.com/mesonbuild/meson/issues/9441>.

* gnu/packages/gnome.scm (gnome-control-center)
[arguments]: Use meson-0.59.
[inputs]: Replace libsoup with libsoup-minimal-2.
-rw-r--r--gnu/packages/gnome.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 00d72cdbc4..bc5fdc3f88 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -8567,7 +8567,8 @@ devices using the GNOME desktop.")
                 "0rr4d5m2a72vrb31jgyx49dp0s2pwgyxsrk4hyw5ym66wq63c3v1"))))
     (build-system meson-build-system)
     (arguments
-     '(#:glib-or-gtk? #t
+     `(#:meson ,meson-0.59         ;positional arguments error with meson 0.60
+       #:glib-or-gtk? #t
        #:configure-flags
        (list "-Dcheese=false"
              (string-append "-Dgnome_session_libexecdir="
@@ -8643,7 +8644,7 @@ devices using the GNOME desktop.")
        ("libnma" ,libnma)
        ("libpwquality" ,libpwquality)
        ("libsecret" ,libsecret)
-       ("libsoup" ,libsoup)
+       ("libsoup" ,libsoup-minimal-2)
        ("libxml2" ,libxml2)
        ("libwacom" ,libwacom)
        ("mesa" ,mesa)